【公告】关于qitmeer-0.9.1-hotfix 版本BUG修复及升级公告

关于qitmeer-0.9.1-hotfix 版本BUG修复及升级公告

在解决社区反馈的一个关于qitmeer-wallet执行中异常报错的问题的过程中(https://github.com/Qitmeer/qitmeer-wallet/issues/54) ,Qitmeer开发团队发现了一个隐藏在qitmeer-0.9.x网络(麦地那2.0网络)中的重大bug。该bug导致在特定情况下,对某些交易的手续费计算出现问题,从而影响了对这些交易以及相关交易的有效性判断。

针对此问题,开发团队已经发布了包含修复补丁的最新版本:0.9.1+hotfix-release-6e0a73a( https://github.com/Qitmeer/qitmeer/releases/tag/v0.9.1-release-hotfix ),该版本将会影响到账户的资产安全,请所有的全节点维护者务必尽快升级到此最新版本。

该Bug的具体技术细节详见(https://github.com/Qitmeer/0.9.1-invalid-utxo/blob/master/README.md)。升级指南和要求见(https://github.com/Qitmeer/qitmeer#09x-testnet-update-warning)。

由于该修复使得某些历史交易被认定为无效,可能导致某些用户的账户余额产生变化。开发团队将采用及时、透明、公开的方式,联系并协调相关方,提供有效的链上证明,协助用户解决无效交易的认定问题。

开发团队新建了 https://github.com/Qitmeer/0.9.1-invalid-utxo 项目,对这个问题的细节进行了详细说明。同时,该项目也用于协助解决无效交易相关问题,如果用户对自己的余额存在疑问,可以访问 https://github.com/Qitmeer/0.9.1-invalid-utxo/issues/ ,建立issue来获得支持。同时Qitmeer浏览器(https://explorer.qitmeer.io/ )也会对所有交易的有效性进行清楚标示,来帮助用户识别无效交易。

目前,钱包和矿池已经恢复转账功能,交易所将陆续恢复充提。对于所有受到此次BUG修复与升级影响的社区用户,Qitmeer向您致以最诚挚的歉意,并感谢您一直以来的支持,愿我们继续携手并进!