【公告】0.9.x Testnet Update WARNING

0.9.x Testnet Update WARNING

:exclamation::exclamation::exclamation: Please update your qitmeer testnet node to the latest version 0.9.1+hotfix-release-6e0a73a immeditally. This release contains a hot-fix for the coinbase fee inconsistent bug #338 which hides inside the 0.9.0/0.9.1 version of qitmeer. The bug results an inconsistent consensus for some transcation which try to spent an UTXO contains coinbase fee. Please update your qitmeer to the latest version and make sure to clean up your local block database and redo the block synchronization.

Please make sure you are using correct qitmeer version, see the commit tag 6e0a73a for sure.

./qitmeer --version
qitmeer version 0.9.1+hotfix-release-6e0a73a (Go version go1.14.4)

Please make sure to clean up your local block database before you start your qitmeer node.

./qitmeer --testnet --cleanup

Qitmeer 0.9.x 节点升级预警

请立即更新你的qitmeer testnet节点到最新版本 0.9.1+hotfix-release-6e0a73a。这个版本包含了一个针对coinbase收费不一致的bug #338 的补丁,这个bug隐藏在0.9.0/0.9.1版本的qitmeer中。

这个bug可能导致一些试图使用包含coinbase费用UTXO的交易出现不一致的共识。请更新您的qitmeer到最新版本,并确保清理您的本地区块数据库,重新进行区块同步。

请确认你使用的是正确的qitmeer版本,请参考 commit 标签 6e0a73a

./qitmeer --version
qitmeer version 0.9.1+hotfix-release-6e0a73a (Go version go1.14.4)

在启动qitmeer节点之前,请确保清理你的本地块数据库。

./qitmeer --testnet --cleanup